Zum Hauptinhalt springen
OpenID

Neu

Thema: Migration eines SMF 2.0.8 (2143-mal gelesen) Vorheriges Thema - Nächstes Thema

0 Benutzer und 1 Gast betrachten dieses Thema.
  • filou
  • [*]
Migration eines SMF 2.0.8
moin moin

Habe alles genau nach Anweisung gemacht
- elk installiert in bestehende SMF Datenbank
- openimp in elk kopiert  und aufgerufen
- Pfad angepasst
- openimp aufgerufen

und bekomme folgende Fehlermeldung

was kann ich nun tun?

danke
LG
  • Zuletzt geändert: 22. September 2014, 15:27 von filou

  • Jorin
  • [*][*][*]
  • Administrator
Antw.: Migration eines SMF 2.0.8
Antwort #1
- openimp in elk kopiert  und aufgerufen
- Pfad angepasst
- openimp aufgerufen

Hast du OpenImp wirklich zweimal aufgerufen?

  • filou
  • [*]
Antw.: Migration eines SMF 2.0.8
Antwort #2
ups nee einmal

  • Jorin
  • [*][*][*]
  • Administrator
Antw.: Migration eines SMF 2.0.8
Antwort #3
Schau mal hier, das Problem gab es mit einer früheren Version des Importers und sollte eigentlich behoben sein, wenn du die aktuellste Version benutzt. Lade dir hier doch bitte mal den Importer frisch herunter, falls du das noch nicht getan hast und vielleicht eine ältere Version benutzt.

Wenn ich es zeitlich schaffe, versuche ich einen Import von meinem SMF 2.0.8 auch einmal. Versprechen kann ich das aber leider nicht.

  • filou
  • [*]
Antw.: Migration eines SMF 2.0.8
Antwort #4
Wollte nun das elk nochmal neu installieren, bekomme dann bei step3 diese Fehlermeldung

Can't find file: 'elkarte_settings' (errno: 2)

Kann doch nüscht wahr sein. Extra Apache neu gestartet. DB wird angelegt

  • filou
  • [*]
Antw.: Migration eines SMF 2.0.8
Antwort #5
Ich bekomme es nicht mehr installiert....

  • Jorin
  • [*][*][*]
  • Administrator
Antw.: Migration eines SMF 2.0.8
Antwort #6
Das kann doch gar nicht sein. Frisches Verzeichnis, neue Datenbank, aktuelles Installationspaket?

  • filou
  • [*]
Antw.: Migration eines SMF 2.0.8
Antwort #7
Hab den kompletten Server neu gestartet, nun isses drauf :-) Und gesichert ^^ Dann auf zum nächsten Versuch

  • filou
  • [*]
Antw.: Migration eines SMF 2.0.8
Antwort #8
So den neusten openimporter runtergeladen und ausgeführt. Keine Fehlermeldung nur eine weisse Seite

  • Jorin
  • [*][*][*]
  • Administrator
Antw.: Migration eines SMF 2.0.8
Antwort #9
Da du bisher der einzige mit solchen Problemen zu sein scheinst, liegt es wohl an deiner Serverkonfiguration. Und da wird dir hier vermutlich derzeit niemand helfen können. @emanuele schaut hier zwar ab und zu mal rein, ist aber der deutschen Sprache nicht mächtig.

  • filou
  • [*]
Antw.: Migration eines SMF 2.0.8
Antwort #10
Glaube kaum das es an der Servereinstellung liegt. Ein Bekannter hat das gleiche Problem bei seinem Anbieter mit dem 2.0.8.

  • filou
  • [*]
Antw.: Migration eines SMF 2.0.8
Antwort #11
Nun eine brachliegende Domain benutzt. Nun bekomme ich diese Fehlermeldung  :o

Antw.: Migration eines SMF 2.0.8
Antwort #12
 emanuele feels is an encoding problem.

Is your forum UTF8 or ISO?

ETA: last time I've seen this error was because some strings had conversion problems between ISO and UTF8.
In this particular case, is the attachments directories array, so: are you using a single directory or multiple? If multiple do you have any special character (anything with accents) in the name of the directories?
  • Zuletzt geändert: 26. September 2014, 00:04 von emanuele

  • Jorin
  • [*][*][*]
  • Administrator
Antw.: Migration eines SMF 2.0.8
Antwort #13
Ich übersetze das mal: Emanuele denkt, es könnte ein Problem mit der Kodierung der Sprachdateien sein. Er meint, sich erinnern zu können, diesen Fehler zuletzt bei einem Fehler mit der Kodierung der Sprach-Strings mit ISO und UTF-8 gesehen zu haben. In deinem Fall geht es wohl um das Attachments-Verzeichnis. Er fragt, ob du mehrere Verzeichnisse für die Attachments verwendest oder nur eines (kann im Administrations-Center eingestellt werden) und ob in deren Namen eventuell Sonderzeichen (z.B. Umlaute) vorkommen?

Ich werde heute auch nochmal mein SMF 2.0.8 in ein frisches ElkArte konvertieren. Ich teile hier das Ergebnis mit.

@emanuele thanks for your answer.
  • Zuletzt geändert: 26. September 2014, 09:36 von Jorin

  • filou
  • [*]
Antw.: Migration eines SMF 2.0.8
Antwort #14
Also.. Erst einmal Danke für Übersetzung von Emanuele und die Tips.
Ich nutze ein Attachmentverzeichnis. Ich habe nu ein neues, leeres attachmentverzeichnis angelegt. Der Fehler bleibt bestehen. In den Dateien im attachment Verzeichnis sind auch keine Umlaute.

  • filou
  • [*]
Antw.: Migration eines SMF 2.0.8
Antwort #15
So hier ist die Lösung für alle die das gleiche Problem haben.

Klickst du hier

Danke Emanuele