Zum Hauptinhalt springen
OpenID

Neu

  • ElkArte - Erste Schritte erklärt dir in leicht verständlichen Anleitungen die Administration und Benutzung eines ElkArte-Forums, leicht verständlich und doch umfassend.

Neueste Beiträge

1
Themes / Antw.: Boardicons und dergleichen
Aktualität von Ruth -
Das bezog sich noch auf die "alte" ElkArte-Version und auf die light-Variante.
"BeSocial" hab ich mir noch nie wirklich angeschaut.

Unter der 1.1. funktioniert der Austausch der Boardicons so über die Anweisungen für die Hintergrundpositionen nicht mehr komplett - zumindest nicht in der Light-Variante. Ich hatte das versucht, es aber nicht vollends hinbekommen.

Zum Austausch der SVG-Boardicons hab ich jetzt was ähnliches gemacht, was im Prinzip auch funktioniert, bis auf die "Legende" unten auf dem Boardindex (da wo erklärt wird, was die Boardicons bedeuten) Diese Icons sollten deutlich kleiner dargestellt, haben aber die gleiche Größe. Dafür habe ich noch gar keine Lösung gefunden...und das schaut ziemlich bescheiden aus. ;)

Ich setze dir mal den gegenwärtigen Code rein, den ich meiner custom.css-Datei diesbezüglich habe, vielleicht kannst du  ja damit was anfangen:

.board_icon {
        display: block;
        float: left;
        margin-top: 5px;
}
.board_key:before {
        display: block;
        float: left;
        height: 24px;
        width: 30px;
        content: "";
}
.category_boards .board_icon, .board_key:before {
background-repeat: no-repeat;}

.i-board-redirect::before{content: url(../../images/_light/redirect.png);}
.i-board-new::before {content: url(../../images/_light/on.png);}
.i-board-sub::before {content: url(../../images/_light/on.png);}
.i-board-off::before {content: url(../../images/_light/off.png);}

#posting_icons .icon {
    vertical-align: middle;
    width: 3em;
}
#posting_icons .buttonlist {
    padding: 5px 5px 0 0;
}
2
Themes / Antw.: Boardicons und dergleichen
Aktualität von Mrs. Chaos -
Man braucht die sechs gewünschten Grafiken, benennt sie entsprechend und lädt sie in das Verzeichnis "images /_light" hoch. Die Grafik "board_icons.png" muß man in der index_light.css auskommentieren, desgleichen die Positionen der einzelnen Grafiken. Statt dessen schreibt man je eine Anweisung für die neuen Hintergrundgrafiken hinein.

.category_boards .board_icon, .board_key:before {
background-repeat: no-repeat;
/*background-image: url(../../images/_light/board_icons.png);*/
}
/*.on_board {background-position: 0 0;}*/
.on_board {background-image: url(../../images/_light/on.png);}
/*.on2_board {background-position: -72px 0;}*/
.on2_board {background-image: url(../../images/_light/on2.png);}
/*.off_board {background-position: -144px 0;}*/
.off_board {background-image: url(../../images/_light/off.png);}
/*.redirect_board {background-position: -216px 0;}*/
.redirect_board {background-image: url(../../images/_light/redirect.png);}
/*.new_some_board:before { background-position: -300px -14px;}*/
.new_some_board:before {background-image: url(../../images/_light/new_some.png);}
/*.new_none_board:before { background-position: -372px -14px;}*/
.new_none_board:before {background-image: url(../../images/_light/new_none.png);}
/*.new_redirect_board:before { background-position: -444px -14px;}*/
.new_redirect_board:before  {background-image: url(../../images/_light/new_redirect.png);}


Ich versuche gerade im Theme "BeSocial" (von der EA-Version 1.1.3) die Board Icons auszutauschen.
Allerdings finde ich in der index_besocial.css nicht diesen Teil oder einen ähnlichen zum auskommentieren. Wo versteckt sich der?:

.category_boards .board_icon, .board_key:before {
background-repeat: no-repeat;
/*background-image: url(../../images/_light/board_icons.png);*/

Gefunden habe ich ab Zeile 1938 nur das. Dort könnte ich ja dann etwas wie .on_board {background-image: url(../../images/_light/on.png);} drunter eintragen(?) :

	.on_board, .on2_board {
background-position: -300px -14px;
}

.off_board {
background-position: -372px -14px;
}

.redirect_board {
background-position: -444px -14px;
}
3
Addons / Antw.: Installieren von manchen Addons geht nicht
Aktualität von Mrs. Chaos -
Sind beide da und stehen auch auf 777.
4
Addons / Antw.: Installieren von manchen Addons geht nicht
Aktualität von Jorin -
Eigentümer muss der FTP-User sein. Außer dem backups-Verzeichnis sollte in dem packages-Verzeichnis noch eine Datei namens installed.lst liegen. Und natürlich eine index.php. Gibt es diese beiden Dateien bei dir?
5
Addons / Antw.: Installieren von manchen Addons geht nicht
Aktualität von Mrs. Chaos -
Ja, ich hatte nur die Datenbank importiert.
Die Dateien aus dem Installationspaket habe ich jetzt noch mal neu hochgeladen und aus irgendeinem Grund wird das Forum nun wieder korrekt angezeigt.
Das Installieren der Addons scheitert aber weiterhin.

Im Paket-Verzeichnis befindet sich nur der Ordner "backups". Beide stehen auf 777.
An dem Wechsel der Besitzrechte zwischen FTP-User und PHP-User liegt das Installationsproblem ja offenbar nicht, denn das hilft hier nicht und war im Testforum auch nicht nötig.
6
Addons / Antw.: Installieren von manchen Addons geht nicht
Aktualität von Jorin -
Beim Importieren hast du aber nur die Datenbank importiert und keine Dateien überschrieben?

Mich wundert, dass ein erneutes Hochladen der unveränderten Dateien aus einem Installationspaket (ohne die install-Dateien natürlich) zu solchen Fehlermeldungen führt.
7
Addons / Antw.: Installieren von manchen Addons geht nicht
Aktualität von Mrs. Chaos -
Ja, ich habe zuerst ein 1.1.3-Testforum installiert und in dem dann acht Addons installiert, um zu sehen, ob die auch mit dieser Version laufen. Die Installationen haben bei allen geklappt, bei keiner davon kamen Fehlermeldungen.

Dann habe ich mein SMF-Hauptforum in ein weiteres neues von ElkArte importiert, was ziemlich umständlich war, da der Open Importer etwas veraltet ist. Und in dem neuen 1.1.3-Forum ließen sich jetzt nur noch vier der Addons installieren, bei den anderen vieren klappt nur das Hochladen auf den Server, aber das Installieren geht dann nicht.
Meisten kommt dann die Fehlermeldung, dass das Paket-Verzeichnis oder enthaltene Dateien nicht überschreibbar sind, obwohl sie das sind, und wenn ich mal zwischen dem Upload und der Installation die Besitzrechte auf "PHP User" ändere, dann kommt die lange Meldung mit "Fehler im Paket "Installation". Es wurde mindestens ein Fehler beim Test installation der Installation des Paketes gefunden. Es wird dringend empfohlen...".
Hm, ich bin echt ratlos, woran das alles liegen könnte.

Habe heute Mittag das mit dem Sichern der Verzeichnisse und Hochladen der "frischen" aus der Installations-Zip probiert, aber damit habe ich nur das ganze Forum zerschossen...
8
Addons / Antw.: Installieren von manchen Addons geht nicht
Aktualität von Jorin -
Momentchen. Erstmal die Ausgangslage definieren. Du hast ein funktionierendes ElkArte-Forum 1.1.3, ohne installierte Addons?
9
Informationen / Antw.: ElkArte - Erste Schritte
Aktualität von Jorin -
Da sonst niemand danach gefragt hat, habe ich auch absolut keine Eile.  ;D
10
Addons / Antw.: Installieren von manchen Addons geht nicht
Aktualität von Mrs. Chaos -
Das hat leider nicht funktioniert. Als ich danach das Forum aufgerufen habe, bin ich auf einer Upgradeseite gelandet, wo diese Fehlermeldung angezeigt wird:

Upgrading Your ElkArte Install!
The upgrader found some old or outdated files.
Please make certain you uploaded the new versions of all the files included in the package.


Habe danach die vorher gesicherten Verzeichnisse wieder hochgeladen, aber jetzt verschwindet die Fehlermeldung nicht mehr.
Ich probiere es mit dem Import in ein EA-Forum gerade noch mal von vorne und ein wenig anders.